Source language: Translate to:

Android App's White Screen

General questions about NeoAppBuilder - our rapid application development tool for building HTML5, web and mobile apps.

Moderator: Neosoft Support

Android App's White Screen

Postby PaulTomo » Sat Sep 12, 2015 5:35 am

I have just searched forum on this but no obvious fixes or answers posted.

When an app is run on the Android phone there is always a moment during startup when the screen is white, may just be milliseconds, then the app displays.

If the internet connection is slow, say in a poor signal area, this white screen shows for a longer time, sometimes making it look like the app has failed to load at all, as all you see is the white screen. Sometimes, by pressing the phones back button it is possible to get the app to display or closing and opening several times!

It seems to me that the app is checking and wanting to connect to the internet, even if it's functionality is fully offline.

Is there a way to fix this?

Maybe some way to force the app to ignore if the internet is there or not, as if any networking is turned off, Wi Fi or Mobile Data, the app will start without it just fine.

Has anyone seen the same and found a way around this, as it's quite annoying when it happens!
User avatar
PaulTomo
 
Posts: 62
Joined: Tue Apr 28, 2009 1:15 am
Location: UK

Re: Android App's White Screen

Postby Neosoft Support » Sat Sep 12, 2015 1:55 pm

I'm not seeing a white screen when starting apps on my phone either with WiFi on or in Airplane Mode. I briefly see a black screen, then the first page of the app appears. Normally an app shouldn't need to access the Internet unless you have linked to resources that are loaded over the Internet like CSS, JavaScript, images, etc. It could also be something specific to certain versions of Android. I'm using v4.4.4 on my phone.

You could try creating a simple one page app with nothing in it and see if the white screen appears. Make the background color of the page something other than white too.
NeoSoft Support
Neosoft Support
NeoSoft Team
 
Posts: 5593
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA


Return to General NeoAppBuilder Discussion

Who is online

Users browsing this forum: No registered users and 0 guests