Source language: Translate to:

RLE corrupts pictures

General questions about using NeoPaint

Moderator: Neosoft Support

RLE corrupts pictures

Postby SysOp » Wed Feb 25, 2015 3:16 am

Saving a bitmap with RLE compression changes the picture and this should not happen. Below is an example. I have circled some differences.

Uncompressed:
Image

RLE compressed:
Image

I hope this can be fixed. Thanks in advance!
SysOp
 
Posts: 16
Joined: Sun Sep 18, 2011 11:36 am

Re: RLE corrupts pictures

Postby Neosoft Support » Wed Feb 25, 2015 4:32 pm

You're right RLE compression shouldn't introduce any distortion in the image. However, I captured your original image from the forum pasted it into NeoPaint. I did see similar distortion when saving to 4bit (16 color) RLE BMP format, but no distortion when saving to 8bit (256 color) format.

I will make a note to correct this in the next update. The BMP filter used in NeoPaint was written by another company, so we'll probably need to consult with them in order to find a solution. Perhaps, in the mean time you can use uncompressed or 8bit RLE?

Sorry for the inconvenience.
NeoSoft Support
Neosoft Support
NeoSoft Team
 
Posts: 5602
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA

Re: RLE corrupts pictures

Postby SysOp » Thu Feb 26, 2015 12:22 am

Thanks! I am using NeoPaint 4 now to save 4-bit RLE compressed bitmaps.
SysOp
 
Posts: 16
Joined: Sun Sep 18, 2011 11:36 am


Return to General NeoPaint Discussion

Who is online

Users browsing this forum: No registered users and 0 guests