Source language: Translate to:

Email

General questions about NeoBook

Moderator: Neosoft Support

Email

Postby Chefman » Tue Jan 28, 2014 8:42 pm

I'm sure I'm missing something somewhere, but I'm having trouble setting up an email link in my publication. I have a hyperlink set up, your basic, 'you can email me here', kind of thing. But when I use the action, it brings up a box for the person to type in their email server. Is there a way just to bring up their own email account to use? I just want them to be able to send me an email with questions, comments etc and I want to make it as easy for the non computer smart people to use. I'm not sure what I am doing wrong but is there a way around this?

thank you!
Chefman
 
Posts: 2
Joined: Sun Jan 26, 2014 4:09 am

Re: Email

Postby dpayer » Tue Jan 28, 2014 9:40 pm

Create a webbrowser object that is off the page.

Insert the following code into the place you want to launch the email from:

Code: Select all
BrowserGoTo "WebBrowser1" "mailto:info@neosoftware.com?subject=Hello from the forum&body=I learned how to populate an email in NeoBook!"


Adjust as needed.

David P.
David Payer
Des Moines, Iowa
USA
User avatar
dpayer
 
Posts: 1380
Joined: Mon Apr 11, 2005 5:55 am
Location: Iowa - USA

Re: Email

Postby Neosoft Support » Wed Jan 29, 2014 11:25 am

You can also do this with the InternetLink action. For example:

InternetLink "mailto:info@youremail.com?subject=Hello from the forum&body=I learned how to populate an email in NeoBook!"

This will open a new email in the user's default email program.

The SendMail action requires a valid mail server in order to work. You can use your email server, account and password, but this can be a security risk. Another option is to use a simple php mail script on your server and call it from NeoBook.
NeoSoft Support
Neosoft Support
NeoSoft Team
 
Posts: 5593
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA

Re: Email

Postby Chefman » Thu Jan 30, 2014 9:56 am

Thank you for your help everyone. :) It's much appreciated.
Chefman
 
Posts: 2
Joined: Sun Jan 26, 2014 4:09 am

Re: Email

Postby Dixan » Fri May 20, 2016 9:58 am

Hello guys,
I tried to use this, when I pushed button it was ok but I closed the e-mail and tried to open it again and not work, I have to close the aplication and open it again to use the e-mail button.
Dix@n
User avatar
Dixan
 
Posts: 51
Joined: Sat May 14, 2016 2:48 pm

Re: Email

Postby Neosoft Support » Mon May 23, 2016 7:34 pm

Which of these commands isn't working for you?
NeoSoft Support
Neosoft Support
NeoSoft Team
 
Posts: 5593
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA

Re: Email

Postby Dixan » Tue May 24, 2016 5:45 am

The commands works perfectly the problem is one I push the button send mail If I push it again no open the mail page and when I change the page and return again to the main page the mail page open automatically, but I solved using (BrowserHome "NavegadorWeb1") at the end of hte command. Thanks
Dix@n
User avatar
Dixan
 
Posts: 51
Joined: Sat May 14, 2016 2:48 pm


Return to General NeoBook Discussions

Who is online

Users browsing this forum: No registered users and 2 guests

cron