Source language: Translate to:

NeoBook 5.6 Beta Released!

Information about NeoBook Updates

Moderator: Neosoft Support

No problems so far

Postby Viviana » Tue Jul 15, 2008 5:49 pm

Installed the program in a new directory:

- no problem on install;
- no "Quick Tour" invitation;
- on first launch, imediately assumed last files opened with previous version (still installed and running)
- all files open correctly
- running and compiling OK
- the program immediately assumed the Plugins installed in the other version of Neobook

Operating system: Windows XP Home Edition - service pack 2 (european portuguese version)

Thanks for the new features :) my favorites are
- comment/uncomment
- word wrap in action editor
- debugger look
- debugger -> long variables as tooltips
- new icons style
... I'm sure I am forgetting a few...

There is still a little detail: altough I configured the publication's language to portuguese, when I check tue program's properties in Windows explorer the language is always shown as English (U.S.)

Congratulations for the great job :)
Posts: 8
Joined: Sun May 25, 2008 6:33 pm

Postby AlfB » Wed Jul 16, 2008 6:36 am

Renaming reg key worked for me, no more Quick Tour invitation, and last used pub is re-openend
HKEY_CURRENT_USER\Software\NeoSoft\NeoBook 5

Try renaming it to

HKEY_CURRENT_USER\Software\NeoSoft\NeoBook 5 Old

But I think this could only be a workaraund, as there is no serial shown now, and I think the Beta works maybe without that.

When I change the registry, no more plugins are installed and I have to re-install/register everything. Don't like to do that...

User avatar
Posts: 132
Joined: Sun Apr 03, 2005 12:43 am

Postby Light » Wed Jul 16, 2008 9:55 am

Odd wrote:Pub made after installing 5.6 beta on Vista 32-bit system (home premium) won't run at all (F9).

Error message: "NeoBook_v5_Test_Publication!!! has stopped working. A problem made the program stop functioning as it should. The program will be closed, and you will be notified if a solution is available. (Close)"

No solution available.

Same with the HangMan sample pub distributed with version 5.5.

Same country, same problem. Vista 32 Bit - SP1
I startet NeoBook, got the Tour question - clicked No

Emty pub :
- clicked Run (this page only) and got the error above
- clicked Run (from start) and got the error above
- clicked Run (from this page ) and got the error above

I compiled a pub on Vista and got the error above
I copied it to win xp sp3 and it worked as it should

event log :

Untitled (Test).exe

- the same error as domino got ... I think
Posts: 38
Joined: Tue Nov 27, 2007 7:47 am

Postby Neosoft Support » Wed Jul 16, 2008 10:12 am

Renaming the registry section is just a temporary solution. Beta 2, due this week, will include a permanent fix.

I'm not seeing the Vista error here, but it may have something to do with the security software used to protect the pub exe. We'll try something different in beta 2.
NeoSoft Support
Neosoft Support
NeoSoft Team
Posts: 5621
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA

Getting the same registry problem with XP..

Postby froxfieldrover » Thu Jul 17, 2008 12:45 am

Hello, a newbie here but many thanks for an excellent program. Just a message to say that I also get the same problem with the "Quick Tour" invitation, but with XP SP3. I did install the beta in a different folder to to the non beta version.

Posts: 4
Joined: Mon Jun 09, 2008 5:38 am

V.5.6Beta OK

Postby Luiz Alfredo » Thu Jul 17, 2008 8:05 am

I'm using Win XP SP3 and it is working fine. If I change in the preferences it does not show the Quick Tour or Last Project any more.
Luiz Alfredo
Posts: 196
Joined: Thu Apr 19, 2007 6:58 am
Location: Brazil

Bug when using "Insert Action -> Loop"

Postby Viviana » Mon Aug 11, 2008 11:13 am

My Loop command stopped working too when I used the "Insert Action" command:
You fill all the fields, and when Neobook inserts the code for you the last line is
instead of
Try to change the command and see if it works

Wrangler wrote:In another existing pub, this code no longer works:

ListBoxDeleteItem "listbox1" "all"

SetVar "[rtinputvar1]" "[pubdir]templates"
SetVar "[rtinputvar2]" "templates.dat"

FileLen "templates.dat" "[flen]"
Loop "1" "[flen]" "[x]"
FileRead "templates.dat" "[x]" "[templatename]"
StrParse "[templatename]" "" "[name]" "[numparsed]"
ListBoxAddItem "listbox1" "0" "[name5]"

Posts: 8
Joined: Sun May 25, 2008 6:33 pm

Postby Wrangler » Mon Aug 11, 2008 1:32 pm

It's supposed to be endloop, at the end of a loop.
"You never know about a woman. Whether she'll laugh, cry or go for a gun." - Louis L'Amour

Windows 7 Ultimate SP1 64bit
16GB Ram
Asus GTX 950 OC Strix
Software made with NeoBook
User avatar
Posts: 1515
Joined: Thu Mar 31, 2005 11:40 pm
Location: USA


Return to NeoBook Upgrade News

Who is online

Users browsing this forum: No registered users and 2 guests