Page 1 of 1

Aplicacion con comportamiento raro

PostPosted: Sat Jul 02, 2016 12:44 pm
by gusgusl
tengo una aplicación con varias paginas
la misma en el "Diseño" se ve correctamente pero si hago un "Ejecute Start" para ver como esta sale toda deformada
Las imágenes con gandes tamaños y todo fuera de lugar

aquí esta la aplicación subida a la web:

guaviyu.org/Dumbo/index.html

esta diseñada para ser vista desde un Smartphone,
es un error de Neoapp o es algún elemento agregado que causa este distorcion?

Aquí esta el código fuente por si lo quieren ver:

http://guaviyu.org/Dumbo/Plataforma%20Web.neoapp

Re: Aplicacion con comportamiento raro

PostPosted: Sat Jul 02, 2016 6:09 pm
by Neosoft Support
Machine Translation:
I have an application with several pages
the same in the "Design" is correctly but if I do a "Run Start" to see how this goes all distorted
Images with gandes sizes and all out of place

here is the climb to the web application:

guaviyu.org/Dumbo/index.html

is designed to be viewed from a Smartphone,
is a Neoapp error or some added element that causes this distortion?

Here is the source code if you want to see:

http://guaviyu.org/Dumbo/Plataforma%20Web.neoapp


I ran your version of the app from your website and everything was jumbled up and out of place just as you described. However, when I ran your app on my PC (using your source code) it displayed correctly. Using the browser's developer mode (F12) to inspect the css while the two version of the apps were running, I found the your version was showing some errors that did not appear on mine. On your version many of the object width and height values used a comma for the decimal separator. For example:

My version:

top: 21.25%;
height: 3.75%;

Your version:

top: 21,25%;
height: 3,75%;

The browser doesn't like the comma (,) being used as a decimal character.

NeoAppBuilder's compiler may be causing this, but I'll have not been able to reproduce it here. Is anyone else having this problem?

As a short term fix you could try temporarily changing your decimal separator to a period (.) in the Windows Control Panel before compiling your app.

Re: Aplicacion con comportamiento raro

PostPosted: Sat Jul 02, 2016 9:31 pm
by luishp
Right now I don't see any problem here:
Ahora mismo no veo ningún problema aquí:

http://guaviyu.org/Dumbo/index.html

Has it been solved?
¿Se solucionó?

Re: Aplicacion con comportamiento raro

PostPosted: Sun Jul 03, 2016 10:24 am
by gusgusl
Hize la compilación desde otra maquina y no me dio ningún problema

Translation:
I made the collection from another machine and did not give me any problems