Source language: Translate to:

Problemas con uso de iframe

General questions about NeoAppBuilder - our rapid application development tool for building HTML5, web and mobile apps.

Moderator: Neosoft Support

Problemas con uso de iframe

Postby gusgusl » Fri Dec 11, 2015 5:43 am

Tengo una pagina con varios botones que al presionarlos me manda a otra pagina donde existe un "iframe" que me abre un link de internet determinado.El link de Internet varia dependiendo de que botón apretemos.
Es por eso que el link de la pagina se lo paso mediante una variable

El problema es que si lo pruebo dentro de NeoAppBuilder funciona perfectamente, pero si lo pruebo ya con la "Apk" generada mediante Phonegap en el celular los links no funcionan, no me abre nada.

Agradezco a quien pueda ayudarme
gusgusl
 
Posts: 254
Joined: Fri Mar 12, 2010 12:44 pm

Re: Problemas con uso de iframe

Postby Neosoft Support » Mon Dec 14, 2015 7:09 pm

This might have something to do with the same origin policy of the websites:

https://developer.mozilla.org/en-US/docs/Web/HTTP/X-Frame-Options
NeoSoft Support
Neosoft Support
NeoSoft Team
 
Posts: 5602
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA

Re: Problemas con uso de iframe

Postby gusgusl » Wed Dec 16, 2015 8:26 am

Alguien me podría orientar de como aplicar esto en mi aplicación porque no me queda muy claro, soy novato en esto
gusgusl
 
Posts: 254
Joined: Fri Mar 12, 2010 12:44 pm

Re: Problemas con uso de iframe

Postby Neosoft Support » Thu Dec 17, 2015 8:29 pm

The sample app called "FormSubmit" shows an example that's similar.
NeoSoft Support
Neosoft Support
NeoSoft Team
 
Posts: 5602
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA


Return to General NeoAppBuilder Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron