Page 1 of 1

NeoAppBuilder Beta Test (Update 15.2.21)

PostPosted: Sat Feb 21, 2015 7:08 pm
by Neosoft Support
An update to the NeoAppBuilder Beta is available for download below:

http://www.neosoftware.com/neoappbuilder.html

Version 15.2.21 includes the following changes:

 Fixed problem that caused previous beta to expire on 2/21/15!!
 Icons are now placed in the correct location when compiling a mobile application.
 Numeric input object’s initial-value property now works correctly (value must be a number).

Re: NeoAppBuilder Beta Test (Update 15.2.21)

PostPosted: Sun Feb 22, 2015 3:25 am
by luishp
Now last version works fine, but previous version remains expired.

In checkbox object, "false-value" and "true-value" have lost their values in an app saved from previous beta version.
As reported, the HTML code inside a Container does not shows any more.
The "SetAttribute" command no longer admits "#" in object name.

Is there any possibility to pre-purchase NeoAppBuilder and keep working with previous beta versions?

Thnk you!!

Re: NeoAppBuilder Beta Test (Update 15.2.21)

PostPosted: Mon Feb 23, 2015 11:44 am
by Neosoft Support
In checkbox object, "false-value" and "true-value" have lost their values in an app saved from previous beta version.


Sorry about that. I believe that the names of those properties were changed slightly which would cause the old values to be lost. Because this is a beta, I can't guarantee that it won't happen again in the future.

As reported, the HTML code inside a Container does not shows any more.


This should be fixed today or tomorrow.

The "SetAttribute" command no longer admits "#" in object name.


This was changed to make it consistent across the interface. We don't use # for ids anywhere else so it didn't make sense to use them for the SetAttribute action.

Is there any possibility to pre-purchase NeoAppBuilder and keep working with previous beta versions?


There will be a purchase option in the near future, but it's not possible to go back to betas that have already expired. Hopefully, you won't want or need to go back.

Re: NeoAppBuilder Beta Test (Update 15.2.21)

PostPosted: Mon Feb 23, 2015 2:57 pm
by David de Argentina
Thanks Dave, great job

On my develop machine (XP SP3, IE 8 ), buttons for webbrowser test (all, Chrome, IE, Firefox & Opera) does not work properly

Chrome and Firefox returns an alertbox with "System error 2. System can't find selected file" or something like this (message is in spanish)

For test, i need compile as html the program and open it with Chrome or FF.

IE: does not work obviously.

Opera: launch webbrowser, but never opens the file.

My 0.01
David de Argentina

Re: NeoAppBuilder Beta Test (Update 15.2.21)

PostPosted: Tue Feb 24, 2015 11:01 am
by Neosoft Support
Hi David,

On my develop machine (XP SP3, IE 8 ), buttons for webbrowser test (all, Chrome, IE, Firefox & Opera) does not work properly


The list of browsers is generated from the following registry sections:

32-bit Windwos: SOFTWARE\Clients\StartMenuInternet
64-bit Windows: SOFTWARE\WOW6432Node\Clients\StartMenuInternet

Can you check the \shell\open\Command keys and see if the paths are correct?

Opera: launch webbrowser, but never opens the file.


This could be that the key above doesn't have the correct "%1" at the end. Or it may be that Opera requires some special command line option to open local files?