Page 1 of 1

Multimedia Object help...

PostPosted: Tue Jun 01, 2010 4:24 pm
by David de Argentina
Hi all,

I'm trying to run this html webpage based on this sample:
http://www.w3schools.com/media/tryit.as ... phicobject

The code is:

Code: Select all
<html>
<body>

<h2>Graphic Object</h2>

<object width="200" height="200" classid="CLSID:369303C2-D7AC-11D0-89D5-00A0C90833E6">
<param name="Line0001" value="setFillColor(255, 0, 255)">
<param name="Line0002" value="Oval(-100, -50, 200, 100, 30)">
</object>

</body>
</html>



But nothing appairs on the Webbrowser object. (neither IE8 or Mozila)
Does anybody tell me if there are a webbrowser security limitation ?
How value I must change in order to run this webpage correctly?
(Windows XP SP3, IE8)

Thanks in advance,
David de Argentina

PostPosted: Tue Jun 01, 2010 5:07 pm
by Gaev
David de Argentina:

According to this ... http://www.ncat.edu/~esterlin/c600s01/Notes/Ch19.pdf ... this CLSID is associated with an ActiveX that provides a web interface for the DirectAnimation subset of Microsoft's DirectX software.

So you might need to install this ActiveX first.

Doesn't work in my IE v7 either ... and of course neither in Firefox 3.5.9 nor Chrome.

PostPosted: Wed Jun 02, 2010 10:56 am
by Neosoft Support
You have to have the ActiveX control installed. You have to be using Internet Explorer (IE is the only browser that supports ActiveX). And you have to have your IE security settings configured to allow ActiveX controls to run.

PostPosted: Wed Jun 02, 2010 1:40 pm
by David de Argentina
Hi Gaev & Dave,

DirectAnimation has two components: (both are found on Windows XP SP3 but not registered)

c:\windows\system32\Daxctle.ocx
c:\windows\system32\danim.dll

I Regsvr32.exe'd both components, and changed for "ask" the security settings for ActiveX... but nothing appairs working...

Any ideas ?

Thanks again,
David de Argentina

DECRAPED....

PostPosted: Wed Jun 02, 2010 4:13 pm
by virger