Source language: Translate to:

Problem with Report Designer

Questions about our Advanced Database plug-in

Moderator: Neosoft Support

Problem with Report Designer

Postby Frederik Gerritsen » Fri Jun 27, 2008 12:34 pm

Hello to all Neobookers,

I have made a msaccess dbase with a password protection

sample :

dbpCreateAccessDatabase "[PubDir]DigiArch.mdb" "Password=3eb2811;Encrypted=Yes"

it does what it had to do but when i want to make a report with report designer i get everytime a error with the message "Wrong Password"
Now is my question is what do I wrong ! Maybe someone give a answere on my question.

Regards
Fred
Frederik Gerritsen
 
Posts: 57
Joined: Tue Apr 11, 2006 3:33 am
Location: Netherlands

Postby Wrangler » Sat Jun 28, 2008 7:27 am

Are you opening the database using the password:

dbpOpenAccessDatabase "mydb" "c:\mydb\mydb.mdb" "passwordhere"

before you call the report?
Wrangler
--------------
"You never know about a woman. Whether she'll laugh, cry or go for a gun." - Louis L'Amour

Windows 7 Ultimate SP1 64bit
16GB Ram
Asus GTX 950 OC Strix
Software made with NeoBook
http://highdesertsoftware.com
User avatar
Wrangler
 
Posts: 1505
Joined: Thu Mar 31, 2005 11:40 pm
Location: USA

Tip who those us Report Designer

Postby Frederik Gerritsen » Sun Jun 29, 2008 4:02 am

Hi Wrangler,

yes i does use dbpOpenAccessDatabase "DigiArch" "[PubDir]DigiArch.mdb" "1eb397"

Then it go wrong so i did try something else with Import Database ID

then i get this :

Provider=Microsoft.Jet.OLEDB.4.0
Data Source=[PubDir]DigiArch.mdb
Jet OLEDB:database Password=******

The it doesn't still work and i know why delete in the DataSource [PubDir] and you get this.

Provider=Microsoft.Jet.OLEDB.4.0
Data Source=DigiArch.mdb
Jet OLEDB:database Password=******

Then the Report Designer can make the connection with de dbase

But it is still strange that report designer can not make a connection with the dbase who is protected with a password and if you choose the file and give wrong password...
Frederik Gerritsen
 
Posts: 57
Joined: Tue Apr 11, 2006 3:33 am
Location: Netherlands

Postby Gaev » Sun Jun 29, 2008 6:20 am

Fred:

i) In your first posting you said ...

dbpCreateAccessDatabase "[PubDir]DigiArch.mdb" "Password=3eb2811;Encrypted=Yes"


Then in your second one you said ...

dbpOpenAccessDatabase "DigiArch" "[PubDir]DigiArch.mdb" "1eb397"


Unless these were just examples, could it be that you are specifying an incorrect password when attempting to open it ?

ii)
Then it go wrong ...

Are you getting the error when you do the dbpOpenAccessDatabase command ... or when trying to generate your report (dbpPrintReport) ?

iii)
... so i did try something else with Import Database ID
From the help file for the Report Designer...
The database source is used only for layout design and testing purposes, and will not be used for the actual report generated from your NeoBook publication. Therefore, the database source specified here must represent the location of the database on your development PC. Since Report Designer operates outside the context of NeoBook, you cannot use variables, such as [PubDir], here. However, if you want your report to be portable, you can replace the path to the database file with "%SourceDir%". For example:

Provider=Microsoft.Jet.OLEDB.4.0
Data Source=%SourceDir%\AddressBook.mdb

This will allow you to move the report file to another folder or PC while maintaining the correct path to the database file. When editing the report, Report Designer will replace %SourceDir% with the folder where the report .dbr file resides. This only affects reports loaded into Report Designer and has no affect on reports generated from your NeoBook publications.

The Import Database ID button can be used to retrieve connection strings from NeoBookDBPro, but you will need to remove any references to [PubDir] and other variables and replace them with literal paths or %SourceDir%.


iv)
But it is still strange that report designer can not make a connection with the dbase who is protected with a password and if you choose the file and give wrong password...


a) make sure you have used the %SourceDir% symbol for the Data Source value.

b) make sure you Save the something.dbr (database report file) after making the change.

c) when you do dbpPrintReport "database id" "report file" "options", make sure you are refering to the database report file saved above.
User avatar
Gaev
 
Posts: 3718
Joined: Fri Apr 01, 2005 7:48 am
Location: Toronto, Canada

Postby Neosoft Support » Mon Jun 30, 2008 11:30 am

I tested the Report Designer with a password protected Access database and it appears to be working correctly. As Gaev suggested, try putting either %SourceDir% or the full path to the database file in the Designer's report properties.
NeoSoft Support
Neosoft Support
NeoSoft Team
 
Posts: 5593
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA


Return to NeoBookDBPro

Who is online

Users browsing this forum: No registered users and 2 guests