Source language: Translate to:

Really Strange Problem - I don't know wh

Questions about our Advanced Database plug-in

Moderator: Neosoft Support

Really Strange Problem - I don't know wh

Postby cp4w » Fri Feb 22, 2008 12:12 pm

I have using DBpro succesfully in my apps. I have it running on many of my customers computers and it works well.

However by one of my customers computers just having a pub with one button that uses the plug-in, even if the button is not clicked causes a major issue.

Code: Select all
dbpOpenDatabase "testmysql" "Provider=MSDASQL.1;Driver={MySQL ODBC 3.51 Driver};Server=localhost;Database=test;User=root;Password=;Option=3"
dbpGetTableNames "testmysql" "--" "[MySqlTableList]"


The issue is that when the application starts it is hidden and does not appear on the screen or in the application list of the task manager, it appears by the procceses so I know it is running.

Any Help?
cp4w
 
Posts: 533
Joined: Sun Apr 03, 2005 4:37 pm
Location: Great Neck, NY

Postby Neosoft Support » Mon Feb 25, 2008 8:16 pm

Hi Steven,

I've only seen this problem once before, but I'm not sure if that person was using DBPro or not. The problem apparently is caused by something in Windows becoming corrupted. It could be a driver or a DLL required by DBPro that's missing, damaged or improperly replaced by another app.

The solution for the other customer was to reinstall Windows, but it may be that simply downloading the latest update patches from Microsoft would work too. Alternatively, you could first try downloading and reinstalling the latest MySQL and Microsoft's database access components - MDAC. MDAC is normally installed as part of Windows, but for older PCs you should be able to find a copy to download from:

http://www.microsoft.com/downloads/Search.aspx?displaylang=en
NeoSoft Support
Neosoft Support
NeoSoft Team
 
Posts: 5603
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA


Return to NeoBookDBPro

Who is online

Users browsing this forum: No registered users and 1 guest