Source language: Translate to:


Questions about our Advanced Database plug-in

Moderator: Neosoft Support


Postby cp4w » Sat Sep 22, 2007 11:19 pm

Using SQLlite When executing dbpExecSQL this is what I get.

Command text does not return a result set

Here is the code
Code: Select all
create table tbl6 as select One from tbl1
Posts: 533
Joined: Sun Apr 03, 2005 4:37 pm
Location: Great Neck, NY

Postby Gaev » Sun Sep 23, 2007 5:38 am


As discussed here ... result+set (way down around Sept/08 to Sep/11) ... and from the Help File description for the results table parameter of the dbpExecSQL command ... Leave this parameter blank to auto detect the table name or if the query does not return any results. ... so you might want to make sure that your command is of the form ...
Code: Select all
dbpExecSQL "yourDatabaseId" "create table tbl6 as select One from tbl1" ""
User avatar
Posts: 3748
Joined: Fri Apr 01, 2005 7:48 am
Location: Toronto, Canada

Postby cp4w » Sun Sep 23, 2007 7:47 am

Gaev thanks,

Tried leaving the result table blank as you suggested. Still get the same message.
Posts: 533
Joined: Sun Apr 03, 2005 4:37 pm
Location: Great Neck, NY

Postby Neosoft Support » Mon Sep 24, 2007 4:00 pm

The presence of "SELECT" in the query causes DBPro to incorrectly assume that there should be a result set. However, the query does appear to work correctly creating the new table, so you should be able to safely ignore this error message. For example:

dbpShowErrors "No"
dbpExecSQL ...
dbpShowErrors "Yes"
NeoSoft Support
Neosoft Support
NeoSoft Team
Posts: 5612
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA

Return to NeoBookDBPro

Who is online

Users browsing this forum: No registered users and 1 guest