Page 1 of 1

PostPosted: Sat Apr 14, 2012 1:16 am
by dec
Hi,

It's a bit rare. I try setting Chrome as the default browser and the command run like a charm here, that is, the internet link is opened on the Chrome browser. Another possible way can be to use the "Run" action, in order to launch the Chrome executable with the appropiate argument (the link URL) however, this implied some things.

For example, you need to find the Chrome executable on the system, and then, you loss the "InternetLink" action: which is responsible to open a link just on the predetermined browser. But I insist: this work like expected on my system (Windows 7) with NeoBook 5. So maybe we have some "rare" problem here.

P.S. In fact NeoBook is not responsible to find the default browser (if I'am not wrong), but just tell to Windows "hey, open this link on the default browser", so, something fail here, but in my opinion this is not a NeoBook or InternetLink action issue.

PostPosted: Sat Apr 14, 2012 1:52 am
by dec
Hi,

pomidor wrote:Probably you are correct... When I try to open link from my e-mail it gives me trouble too. Only when I had IE as the default browser it worked well. Have to look in windows to find the bug.


Exactly. You are doing the more correct test: trying to open the default browser with other program, like your email program. If this fail (that is the case) then the problem is not on NeoBook or "InternetLink" action, but in the whole system. Maybe Chrome cannot be the default browser because the user who set this option cannot the appropiate privileges? Can you try setting another browser (like Opera) as the default browser? Search also on Internet about this problem, something like "Windows don't change the default browser", in order to possibly found some information.

PostPosted: Sat Apr 14, 2012 5:33 am
by Gaev
pomidor:

If you want to check what the system thinks your default Browser is ... try this ...
Code: Select all
Run "!C:\somePath/someFile.htm" "" "Normal" "" ""
... it will cause the associated Browser to be opened in the new Window ... my default is Firefox (under XP Pro SP3) ... and it opened the file in Firefox ... but then ...
Code: Select all
InternetLink "http://www.scriptedlogic.com"
... also worked as expected.