Source language: Translate to:

DownloadFile

Questions about using NeoBook's scripting language

Moderator: Neosoft Support

DownloadFile

Postby smartmedia » Mon Jan 24, 2011 12:40 am

Hi..

I use DownloadFile with HideProgress+Async options. I complied using the default option. When i run the exe in Windows 7 home premium the command is not running. I must run it as administrator in order to run... I must do any change in complie options..??? Or is bug...???

Thanks
User avatar
smartmedia
 
Posts: 889
Joined: Fri Apr 01, 2005 6:50 am
Location: Hellas

Postby Neosoft Support » Mon Jan 24, 2011 12:03 pm

I think downloading a file would fall under things that require admin privileges since it's potentially dangerous.

As a general rule, NeoBook cannot circumvent Windows User Access Control (UAC) security. If it could, then the security would be worthless.
NeoSoft Support
Neosoft Support
NeoSoft Team
 
Posts: 5593
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA

Postby Wrangler » Mon Jan 24, 2011 12:14 pm

Unless you have a large number of users on the same machine, you may think about disabling UAC. In my install of win7, I am a single user as Admin. Thusly, I can access anything I want to. I disabled UAC from the beginning, and have no problems.

Disabling any kind of security should be considered extensively. But in my opinion, UAC is designed for those who lack expertise in running and maintaining a computer. And have multiple users such as mom and pop and kids. Each user is controlled individually.

UAC in Vista is much more obnoxious. And difficult to control. My suggestion if you're running Vista is to upgrade to Win7, which is what Vista should have been in the first place.
Wrangler
--------------
"You never know about a woman. Whether she'll laugh, cry or go for a gun." - Louis L'Amour

Windows 7 Ultimate SP1 64bit
16GB Ram
Asus GTX 950 OC Strix
Software made with NeoBook
http://highdesertsoftware.com
User avatar
Wrangler
 
Posts: 1505
Joined: Thu Mar 31, 2005 11:40 pm
Location: USA

Postby smartmedia » Mon Jan 24, 2011 12:55 pm

Hi..

That is the problem.. UAC is disabled and none message is appearing on screen. It just don't download. If i run as Administrator everything is ok. I will look into it more tomorrow and tell you..
User avatar
smartmedia
 
Posts: 889
Joined: Fri Apr 01, 2005 6:50 am
Location: Hellas


Return to NeoBook Action Commands

Who is online

Users browsing this forum: No registered users and 1 guest

cron