Source language: Translate to:

BrowserSetElement

Questions about using NeoBook's scripting language

Moderator: Neosoft Support

BrowserSetElement

Postby Alex » Tue Feb 13, 2007 11:05 am

Hi,

I have a problem, the BrowserSetElement function doesn't work anymore !!!

For example, I want it writes my name to a forum inscription (I win time), it saied Error.



Look at my code :

BrowserSetElement "WebBrowser1" "Pseudo" "[Name]"

I write my pseudo in a variable [name], I set the link : http://forum.hardware.fr/inscription.ph ... warefr.inc
and click of the oush button where there is the BrowserSetElement and nothing work. Why ?



Thank you very much


Alex
Alex
 
Posts: 745
Joined: Sat Mar 04, 2006 4:53 am

Postby Neosoft Support » Tue Feb 13, 2007 11:18 am

I tried the following and it seemed to work correctly:

Code: Select all
BrowserSetElement "WebBrowser1" "Pseudo" "Alex"


If your code isn't working, check the contents of the variable [Name] and make sure it's not empty. If it's empty, then it might appear that BrowserSetElement isn't working.
NeoSoft Support
Neosoft Support
NeoSoft Team
 
Posts: 5605
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA

Postby Alex » Tue Feb 13, 2007 11:26 am

Thanks,

I don't know why, but now it is working

Thanks again


Alex
Alex
 
Posts: 745
Joined: Sat Mar 04, 2006 4:53 am

Postby datadon » Tue Feb 13, 2007 4:34 pm

This is just a thought, but the lastest version the IE, I think it is 7, does not respond in the same way that version 6 did. For example, I have a program that auto applies my passwords then used to submit the form at the same time. It does not do that with IE7. It nolonger auto submits, I must press the submit button, so I think something may have changed. Have not checked it out with NB actions as of yet.
Don

'If you want to get a brontosaurus from 'a' to 'b' then you ride the dinosaur - you don't carry it!'
User avatar
datadon
 
Posts: 389
Joined: Sun Apr 03, 2005 7:55 pm
Location: Lorena Texas

Postby Neosoft Support » Tue Feb 13, 2007 4:54 pm

As far as I can tell BrowserSetElement appears to be working well with IE7.
NeoSoft Support
Neosoft Support
NeoSoft Team
 
Posts: 5605
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA


Return to NeoBook Action Commands

Who is online

Users browsing this forum: No registered users and 2 guests

cron