Source language: Translate to:

CheckInternetConnection action

Questions about using NeoBook's scripting language

Moderator: Neosoft Support

CheckInternetConnection action

Postby Frederik Gerritsen » Thu Jul 20, 2006 11:55 pm

Hi All,

I have a question, I do use the next action command from Neobook called CheckInternetConnection "[Result]" and did set it on a Timer and evere 1000 miliseconds is checked of the programm still be connected to internet. I do use wireless lan connection, when i run the command the timer worked perfectly, then the result is True, but when i lost my connection then i get as Result false, so far verything is be ok. But when I restart the connection of my wireless lan the command CheckInternetConnection "[Result]" doesn''t work anymore, the result stay on False. What goes wrong or what i be doing wrong ? Maybe someone have a idea about this.

Regards
Fred Gerritsen[/b]
Frederik Gerritsen
 
Posts: 57
Joined: Tue Apr 11, 2006 3:33 am
Location: Netherlands

Postby Neosoft Support » Fri Jul 21, 2006 11:40 am

NeoBook's CheckInternetConnection action simply executes a Windows function called "InternetGetConnectedState" and returns the results (true or false). I can't exaplain why it doesn't work in your example. It could be a bug in Windows or it could be that it takes a while for the connection to be restarted.

One thing you might try is calling NeoBook's ConnectToInternet action when CheckInternetConnection fails. If the loss of the connection results in Windows going into an off-line mode, then this may correct the problem.
NeoSoft Support
Neosoft Support
NeoSoft Team
 
Posts: 5593
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA

Postby Apoleo » Sun Mar 25, 2007 8:11 am

Hi, i've got this problem too. CheckInternetConnection shows me randomly False or True when I'm always connected. does InternetGetConnectedState check any port to get this information?
User avatar
Apoleo
 
Posts: 88
Joined: Sat May 14, 2005 1:17 pm
Location: Sevilla, España

Postby Neosoft Support » Mon Mar 26, 2007 9:53 am

Here is some more information on Microsoft's InternetGetConnectedState function which is what NeoBook's CheckInternetConnection action used to determine if an Internet connection is active:

http://msdn2.microsoft.com/en-us/library/aa384702.aspx

http://support.microsoft.com/kb/315035
NeoSoft Support
Neosoft Support
NeoSoft Team
 
Posts: 5593
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA

Postby Apoleo » Wed Mar 28, 2007 7:29 am

Hi, I think the problem resides in Internet Explorer 7. I've uninstalled it to my last version (6.0.2900.2180.xpsp_sp2_qfe.061219-0311) and the action command works perfectly. Maybe InternetGetConnectedState in IE7 have some bugs but i don't really know. Thanks for the information :wink:
User avatar
Apoleo
 
Posts: 88
Joined: Sat May 14, 2005 1:17 pm
Location: Sevilla, España

Postby Neosoft Support » Wed Mar 28, 2007 5:33 pm

Maybe InternetGetConnectedState in IE7 have some bugs but i don't really know.


That's certainly possible. I will make a note to look into this for the next update.
NeoSoft Support
Neosoft Support
NeoSoft Team
 
Posts: 5593
Joined: Thu Mar 31, 2005 10:48 pm
Location: Oregon, USA


Return to NeoBook Action Commands

Who is online

Users browsing this forum: No registered users and 1 guest