Source language: Translate to:

tmMacro - Add Macro Record/Play

Plug-ins and utilities of interest to NeoBook authors

Moderator: Neosoft Support

tmMacro - Add Macro Record/Play

Postby Alberto Meyer » Tue Jun 08, 2004 7:58 am

Hi. tmMacro can add Macro Record/Play funcionality for Neobook 4. You can create your macros, store, and play it later.

http://plugins.techmedia-software.com.br


It´s shareware. If you find it useful, give it a try.

All the best

Al
Alberto Meyer
 

tmMacro

Postby HPW » Tue Jun 08, 2004 8:57 am

Hello Alberto,

it has been good habit that all developers use their prefix for commands and variables.

So how about:

tmMacroRecordStart
tmMacroRecordStop
tmMacroPlay
tmMacroCheckFinish

[tmVarMarcroFinished]
[tmVarMacroFilename]

So we avoid name conflicts and get readable scripts.
Just a thought! ;-)
HPW
 

tmMacro

Postby Alberto Meyer » Tue Jun 08, 2004 9:10 am

I´m using tm for plugin names. For plugins actions, i think we can follow the Neobook rules, when each kind of functions have their own prefix. It´s easier to the final user, I Think.

But I think people can vote about that.
Alberto Meyer
 

tmMacro

Postby Gaev » Tue Jun 08, 2004 10:00 am

Alberto:

But I think people can vote about that.

I am (mostly) with Hans-Peter on this ; with the recent proliferation of plug-ins, it is imperative that there be some order in the naming of plug-in commands and reserved variables.

So, if you want to use the "mr" prefix for commands in this plug-in (mrStart, mrStop etc.), it would be Ok (as long as another developer has not already chosen the same) ; and I might suggest that (for the convenience of your users) you maintain a consistency with the name of the plug-in (i.e. also name your plug-in mrMacro.nbp).

As for the variables used in the sample pub, it is not clear if these are hard coded values the developer has to use (in which case the same "mr" prefix should be used) or just any variable the developer can specify (in which case the names chosen in a sample are immaterial).

It doesn't take any more effort to exercise such discipline but pays huge dividends in benefits to the NeoBook Developer community.

I haven't developed plug-ins (yet) but whenever I submit generic SubRoutines for general use, I deploy the same format for internal (local) variables deployed in such routines ; so, people wanting to use them do not have to worry about messing up the values of some existing variables with the same name.
User avatar
Gaev
 
Posts: 3736
Joined: Fri Apr 01, 2005 7:48 am
Location: Toronto, Canada

tmMacro

Postby djold1 » Tue Jun 08, 2004 10:38 am

I absolutely agree with the suggestions of gk51 & HPW. We are getting a lot of new plug-ins and there has to be some sort of standard or chaos will result.

The subject of peer review by experienced users to pass on the general form, style & usability of a plug-in was brought up some time ago, I think, and in my opinion it is becoming much more necessary.

Unfortunately, many developers have abandoned the idea of a text description of the plug-in for the user and a text help file that details the usage of every function within it. Instead, a Demo is built that kind of demonstrates the use, but doesn't really cover everything.

I guess this is OK if you are doing free software, but in my opinion is a self serving shortcut. It should never happen with commercial plug-ins. Look at Ronnie's Doc's. That is the right way to do it.

It also might be a good idea if NeoSoft were to issue a general style description and include it with the SDK.

While I'm whining, I would also like to suggest that developers of plug-ins provide a comprehensive description of what the plug-in does when they announce it in this forum. If I am using NeoBook in another field than Web Development and if I have, for whatever reason, not much experience in that area, then the headline "Announcing the New Fabulous WebSnooker" doesn't tell me anything. Some of the stuff coming out looks great, but frankly I don't have a clue as to its useage or advantages. How about a little sales pitch?  I don't have time to download and try everything.

Whine mode off. Thank you kindly..
djold1
 

tmMacro

Postby Alberto Meyer » Tue Jun 08, 2004 10:50 am

Ok. I agree. I will put tmPrefix as my standart convention. About the PlugIn Title on Forums, I try to put it more clear as possible: Just look at my plugins name. And you are right about the documentation. I will try to put the docs more clear.

About the Vars, the docs must be clear about that.
Alberto Meyer
 

tmMacro

Postby Alberto Meyer » Tue Jun 08, 2004 12:35 pm

All files in my site has been updated, to follow the rules: all commands and "hard" variables needed have the "tm" prefix. The "Ronnie Style" manual, follows. Itá a little difficult for me write in english, but the source code in pub can make the job for a while. The "ReadMe.txt" has the commands and error codes.

Sorry for any inconvenience.

Cheers

Al
Alberto Meyer
 

tmMacro

Postby HPW » Tue Jun 08, 2004 1:24 pm

Hello Alberto,

After a look atyour updated plugin, I see that you have named the command: tmStart

It sound's from you posts that you want to make a lot more plugins. So give it a second thought with your naming convention. When tm.... is your prefix you will have a lot of times somthing to ...Start.

So as someone who has made some plugins with some more commands I had vote for: tmMacroRecordStart

So notation is developer.plugin.functiondescription.
I know it is a bit more typing, but it is self-explanatory and offers simple reading (even when you do not have a Look for a long time to your source)

So take it just as a note/vote from a potential customer!

;-)
HPW
 

tmMacro

Postby Alberto Meyer » Tue Jun 08, 2004 1:37 pm

ROL, Hans :) :)
I agree. I paid attention in the prefix and didn´t take care of the sufix. You are right. It´s easier to fix. It´s good idea to put long command names. Better describe the commands.
Alberto Meyer
 

tmMacro

Postby Gaev » Tue Jun 08, 2004 4:45 pm

Alberto:

Thank you for that unselfish act of caring (for your clients) ; may be other plug-in developers should take note ; just look at Hans-Peter's Plug-In Assembley Line (a plug-in a day keeps HPW coding away) ... to visualise the mess that could develop without some naming conventions.
User avatar
Gaev
 
Posts: 3736
Joined: Fri Apr 01, 2005 7:48 am
Location: Toronto, Canada

tmMacro

Postby HPW » Tue Jun 08, 2004 10:26 pm

And on the long run maybe we get an editor similar to a Visual Studio or Borland IDE with code completition etc. (It is possible today with several external editors).

Also when you have a look at something like the .NET framework, you will see very long and descriptive naming. (with support through namespaces and regions)
HPW
 

tmMacro

Postby djold1 » Wed Jun 09, 2004 2:52 am

Thanks Alberto..
djold1
 

tmMacro

Postby Alberto Meyer » Wed Jun 09, 2004 4:12 am

Yes, Hans. I´m thinking in a outside IDE for a long time, but the Neobook actions scripts are very short, so I´m thinking about the useful of this stuff.

I´m a beta tester of several Microsoft products, so I know the .NET framework very much. But name conventions are, usually, ignored by programmers. :) Well, it´s a good idea follow the rules heres.
Alberto Meyer
 


Return to NeoBook Plug-Ins and Utilities

Who is online

Users browsing this forum: No registered users and 1 guest