Page 1 of 1

UPX problem, help !

PostPosted: Fri Aug 04, 2017 4:22 am
by dglojnar
Well, suddenly I have a problem with compiling my PUB.
UPX option is turned ON, but I receive error message "UNABLE TO COMPRESS EXE. UPX EXIT CODE 1"

I'm working on Linux Mint with VmWare XP install.
XP don't have any access to any network/Internet, and I put fresh Neobook installation with all plug-ins I need.

Also, try to compile without UPX (work OK) and run UPX separatelly - received following message: "CANTPACKEXCEPTION: .NET files are not yet supported"

Try with UPX 3.08w (come with Neobook installation) and 3.94 (the latest version).

What can I do ?
What I'm doing wrong ????

Re: UPX problem, help !

PostPosted: Fri Aug 04, 2017 4:27 am
by dglojnar
I forgot, Neobook version is 5.8.7, Windows XP SP3 on VmWare Player 12.5 Linux Mint host

Re: UPX problem, help !

PostPosted: Sun Aug 06, 2017 11:01 am
by Neosoft Support
UPX is a separate program, not part of NeoBook, so I don't think there is anything we can do. It could be something compiled inside your publication (embedded file, plug-in) that's causing UPX to fail. Your best bet would be to turn off the UPX option in NeoBook and experiment with adding the UPX compression manually. UPX has many command line options, and probably there is one that may solve the problem.

Re: UPX problem, help !

PostPosted: Sun Aug 06, 2017 1:33 pm
by dglojnar
Thank You Dave, I try what can I do:-)))


Regards!