Page 1 of 1

Please Help

PostPosted: Mon Dec 12, 2016 1:54 pm
by Dudus
Hi folks,

please help. When I use and work on a Webbrowser in neobook the webpage form looks cool, but after I start the pub it's crashing.
Where is the problem?

Image

Thank you!
D

Re: Please Help

PostPosted: Mon Dec 12, 2016 3:46 pm
by virger
Revisa tu .CSS y su compatibilidad con el IE, prueba el html con Firefox, IE y Chrome, no es tu programacion en NeoBook

Re: Please Help

PostPosted: Tue Dec 13, 2016 12:32 am
by Dudus
Hi,

my issue is that on chrome, mozilla and IE works great - even in neobook preview before you start the pub, but WHEN you start the pub than it is like on the picture...
Is it because i use only a Trial version of neobook? I think the answer shall give me NeoSoft.

D

Re: Please Help

PostPosted: Tue Dec 13, 2016 2:50 pm
by mishem
Verify the path to the file. CSS.
I think its not there looking for NeoBook. NeoBook trial here at anything.

Re: Please Help

PostPosted: Tue Dec 13, 2016 7:23 pm
by Neosoft Support
It's probably something to do with the browser emulation mode. Your website works in NeoBook because NeoBook's installer sets the browser emulation mode in the registry. Compiled pubs should do this too, unless something on your PC is preventing it from working. The topics below may be helpful:

http://www.neosoftware.com/community/viewtopic.php?f=22&t=20833&p=11215915&hilit=BROWSER+EMULATION

http://www.neosoftware.com/community/viewtopic.php?f=24&t=20784&p=11215717&hilit=BROWSER+EMULATION

Re: Please Help

PostPosted: Thu Dec 15, 2016 2:35 am
by Dudus
My pub is on stage 99,9% only this one is the problem, to set dword:0 (as a default IE emulator)

and I do not know how to write into the Registry as before someone mentoined on forum:

RegistryWrite "HKEY_CURRENT_USER" "SOFTWARE\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION" "MyProgram.exe=dword:0"

This above is not working!
Please help me how to put a wroking code into neobook.

Thanks!
D

Re: Please Help

PostPosted: Fri Dec 23, 2016 4:39 pm
by Neosoft Support
Microsoft no longer accepts zero as an option. You have to use 11001 for IE 11.

Re: Please Help

PostPosted: Sun Dec 25, 2016 5:05 am
by Dudus
Thank you, an what will be if my software user has only IE9 or less than?

Re: Please Help

PostPosted: Wed Dec 28, 2016 7:32 pm
by Neosoft Support
In most cases NeoBook apps will handle this automatically. Only if your PC has something that prevents the app from setting the registry, should you need to handle this yourself.

Unfortunately, Microsoft* made this much more complicated than it needed to be. There are different settings for each version of IE. A description of these settings can be found below:

http://stackoverflow.com/questions/4456490/how-to-set-feature-browser-emulation-to-ie8-mode

As for which one to use, you will need to detect which version of IE is installed. You can probably find this in the registry somewhere.

*Feel free to send complaints to Microsoft.

Re: Please Help

PostPosted: Thu Dec 29, 2016 7:01 am
by virger