Page 1 of 1

SORT DATABASE

PostPosted: Sat Apr 09, 2016 3:43 am
by StarterPack
Hi Guys, I've Created a database with NEOBOOKDB 2.3d. How do I SORT my database A-Z, cause the Sort function does'nt work or maybe I've done it wrong. Thank You

Re: SORT DATABASE

PostPosted: Sat Apr 09, 2016 5:20 am
by Gaev
StarterPack:

the Sort function does'nt work or maybe I've done it wrong

If you post your code here, someone will tell confirm it one way or another.

Re: SORT DATABASE

PostPosted: Sat Apr 09, 2016 6:10 am
by StarterPack
Hi Gaev. It's The Normal SORT function from NeoBookDB 2.3d - Under "Sort/Index (dbSort)"
I create a Folder named "TEST" on my C Drive and build the program until i'm ready to compile.

Well, this is the code I have for my database named "VendorsList"
dbfSort "C:\TEST\VendorsList" "" "VENDOR|CONTACT NR|PERSON 1|PERSON 2|TYPE PARTS" "Ascending"

Thank You

Re: SORT DATABASE

PostPosted: Sat Apr 09, 2016 8:38 am
by Gaev
StarterPack:

I create a Folder named "TEST" on my C Drive and build the program until i'm ready to compile.

Note that you can run your pub (for testing) without first compiling it (check out what Book >>> Run from Start or press Function key F9).

Well, this is the code I have for my database named "VendorsList"
dbfSort "C:\TEST\VendorsList" "" "VENDOR|CONTACT NR|PERSON 1|PERSON 2|TYPE PARTS" "Ascending"

Not clear if you are invoking this after you have invoked commands like dbfCreate/dbfOpen, dbfAddRecord etc etc.

If you have, then ...

a) does your database file (VendorsList) have a .dbf file extension ? ... you do not specify it in your dbfSort command

b) I am not sure you can have spaces in field names like your CONTACT NR, PERSON 1, PERSON 2 and TYPE PARTS ... I think this is a restriction of the dBase type of database deployed with this plugin.

c) in your dbfSort command ...

- place an ! character before the database file name
- specify a value for the second parameter (e.g. !C:\TEST\VendorsList.ndx)

Re: SORT DATABASE

PostPosted: Sun Apr 10, 2016 1:41 am
by StarterPack
Hi Gaev

Thank You Very Much.... Works Now : )