Page 1 of 1

IE11/Win8.1 problem with WebBrowser object

PostPosted: Mon Dec 28, 2015 9:12 pm
by Tony Kroos
Just found a strange bug with my IE11/Win8.1 and WebBrowser object.

Create a new untitled project and create new empty WebBrowser object.
Neobook hangs and not responding when:
- trying to set an URL in object properties. Set URL, click OK, dialog disappears -> nb hangs.
- trying to save project with empty wb object. Click File-Save as, enter name, click OK -> nb hangs.

IE version - 11.0.9600.18098
Update version - 11.0.25 (KB3100773)
NB version doesn't matter.

Can anyone confirm this?

Re: IE11/Win8.1 problem with WebBrowser object

PostPosted: Mon Dec 28, 2015 11:41 pm
by HPW
Hello,

Not 8.1 but a test on my Win7 tablet works ok.

IE version - 11.0.9600.18124
Update version - 11.0.26 (KB3104002)
NB Version 5.8.6

Regards

Re: IE11/Win8.1 problem with WebBrowser object

PostPosted: Tue Dec 29, 2015 12:11 am
by Tony Kroos
Just updated IE to build 18125, have the same issues... will investigate more.

Re: IE11/Win8.1 problem with WebBrowser object

PostPosted: Tue Dec 29, 2015 7:34 pm
by Neosoft Support
I'm not able to reproduce this here (using NeoBook v5.8.6, IE v11.0.10240.16431 and Windows 10).

It sort of sounds like Windows or your firewall/AV thinks NeoBook isn't allowed to access the Internet. NeoBook might not be stuck, but just waiting for the Internet request to timeout which might take a minute or so.

Re: IE11/Win8.1 problem with WebBrowser object

PostPosted: Tue Dec 29, 2015 8:31 pm
by Tony Kroos
Disabling AV has no effect.
When started, neobook spawns two neobook.exe processes (never noticed this before, is it correct?)
When traversing wait chain in task manager it shows that one process waits for another indefinitely (deadlock?)

But then some magic things happened when I tried to attach debugger to neobook.exe process, it told me that will never work under debugger and terminated. After that, all issues have gone.
I guess these issues was caused by the fact that multiple versions of neobook (5.6.4/5.7.0/5.8.6 trials) installed and used on the same machine, maybe something went wrong with armadillo protection environment.

Re: IE11/Win8.1 problem with WebBrowser object

PostPosted: Wed Dec 30, 2015 7:16 pm
by Neosoft Support
I have no idea. Maybe something on your PC became corrupted then fixed itself?