Page 1 of 1

"Cannot create file"

PostPosted: Thu Nov 19, 2015 12:18 pm
by seanie
I tried to modify (for the 5th or 6th time) an existing .pub, and got the following error message:

"Cannot create file. Unable to access compiler resource file. Please reinstall NeoBook."

I thought perhaps this was a Windows 10 problem, but now it has also happened on Windows 7 as well. Is this because I made multiple modifications? Both times the error occurred when I clicked the 'Run (from this page)' test button.

I haven't reinstalled yet, but I'd love to know what happened and how to avoid this in the future - if possible :)

I'm using Version 5.5.4 Professional. Would upgrading help? :)

Thanks!

Re: "Cannot create file"

PostPosted: Thu Nov 19, 2015 10:21 pm
by Tony Kroos
Check your security settings. Try to disable your anti-virus or install into different folder (not c:\program files\...)

Re: "Cannot create file"

PostPosted: Fri Nov 20, 2015 6:13 pm
by Neosoft Support
The "unable to access compiler resource..." error is usually caused by an invalid path in the Compiler's "File name and folder for compiled publication" field. To fix the problem, select "Compile/Publish" from NeoBook's "Book" menu, then make sure that the above field is a valid location/file name. As Tony suggested, use a folder that Windows will allow you to write to like "Documents".

Re: "Cannot create file"

PostPosted: Sat Nov 21, 2015 7:05 am
by seanie
Thank you Tony Kross and Neosoft Support for your responses. I have had problems since upgrading my antivirus, so I will check that out. By the way, in the case of both computers, I do have my NeoBook pubs in 'write-to' locations. In the case of my Windows 7 'puter, I save to `Documents'; and on the Win 10, my pubs write to a folder on the desktop.

Thanks again for your time.

Peace!

Re: "Cannot create file"

PostPosted: Tue Nov 24, 2015 5:28 am
by seanie
UPDATE:

I have reinstalled on the Windows 10 computer, but the problems persist. I turned off my antiV (Avast), but NeoBook will not run .pubs (I'm not getting the error message; nothing happens). Worse, compiled .exe files will not open at all. I'm going to try completely deleting Avast from my Win 7 computer to see if that works.

Do you think an upgrade of NeoBook might help? Does it make a difference that my computers are 64-bit and NeoBook is 32-bit?

Re: "Cannot create file"

PostPosted: Tue Nov 24, 2015 8:44 am
by Wrangler
Do you have .pub files associated to run with Neobook? If you're double clicking the files to launch them in Neobook, it would be required.

Re: "Cannot create file"

PostPosted: Wed Nov 25, 2015 4:19 am
by seanie
Hi Wrangler,

Yes, I did the asociaciĆ³n during the installation (and I don't have Microsoft Publisher, so no potential for conflict). But when I said the .pub wouldn't run, I was referring to the last .pub that I was working on which opened up automatically when I launched NeoBook. When I clicked the Run button, nothing happened. I did not double-click on the .pub file. In fact, I have never done that. I always navigate to .pub files through NB itself.

Anyway, after the abovementioned incident, I did double-click on something in my NB folder (created on the desktop). That was an .exe file made months (possibly years) ago and it, too, would not open. Technically, that shouldn't have anything to do with NeoBook, right?

So I'm thoroughly confused. It's as if both .pubs and .exes (at least the ones created with NeoBook) have ceased working on both computers. My next experiment will be to remove Avast completely from my Win 7 computer and try again. I'll report on what happens thereafter.

Thanks for your interest.

Re: "Cannot create file"

PostPosted: Wed Nov 25, 2015 5:24 pm
by Neosoft Support
It's very strange that Windows isn't giving you any error messages at all. I have no trouble running NeoBook-created exes (even old ones) under Windows 10 here. I'm not using Avast - just the AV included with Windows 10. It could be Avast or it could be something in your pubs. There is a known problem with NeoBook's Flash player not working under Windows 10 - which we haven't found a solution to yet.

One thing you might try is downloading the current version of NeoBook (5.8.6) and installing it into a different folder. Then try compiling and running one of your pubs and see if that works.

Re: "Cannot create file"

PostPosted: Sun Nov 29, 2015 4:07 pm
by seanie
No Windows error messages. The 'circle thingie' just goes round and round, and nothing happens.

Anyway, I uninstalled Avast from my Windows 7 computer, reinstalled NeoBook, and now it works fine. I guess I will have to do the same with my Win 10 computer. This is bit of a high price to pay - literally - since I'm not using the free version of Avast. :) But Avast has been causing other problems, like making trusted websites take a long time to load or not load at all.

I wonder what the most NeoBook-friendly antiV programme is.... I feel a bit 'vulnerable' without one.

Have a great week!

Re: "Cannot create file"

PostPosted: Sun Nov 29, 2015 4:44 pm
by Gaev
seanie:

I feel a bit 'vulnerable' without one

My understanding is that when Windows 10 finds an unprotected machine, it automatically implements its own Windows Defender protection program.

Not sure about Windows 7.

Also, Avast might have features where you can exclude folders from its (over reaching) protective actions ... hopefully, hackers don't have a method of finding out which folders are so designated by you.

Re: "Cannot create file"

PostPosted: Mon Nov 30, 2015 7:05 pm
by seanie
Thanks Gaev. I'll look into whether Avast has such a feature. Perhaps I could write to them as well. Cheers!

Re: "Cannot create file"

PostPosted: Mon Nov 30, 2015 7:26 pm
by Neosoft Support
Windows Defender seems to be perfectly adequate.