Page 1 of 1

Unable to compile icon

PostPosted: Fri Jun 19, 2015 4:32 pm
by tjchan
Hello, I'm getting a problem with the latest 5.8.5b version of NeoBook. It keeps giving me the error Unable to compile icon. This works on 5.8.5. Is there a fix/workaround for this? If not, where/how can I download a previous version of NeoBook?

Thanks!
-Timothy

Re: Unable to compile icon

PostPosted: Sat Jun 20, 2015 6:21 pm
by tjchan
I made an error. On my laptop it happens it is the same version 5.8.5b and that is working. The oddity is that:

Laptop:
Windows 8.1 Standard User

Desktop:
Windows 7 Administrative User locally but not for my domain.

Any thoughts on why it works on one but not the other on the same icon resource?

Thanks!
-Timothy

Re: Unable to compile icon

PostPosted: Mon Jun 22, 2015 5:06 pm
by Neosoft Support
It could be that the icon file isn't where NeoBook expects it to be. Try going to the Book Properties and selecting the icon file again.

Re: Unable to compile icon

PostPosted: Wed Oct 21, 2015 1:00 pm
by Rasl
Same problem with Neobook 5.8.6 , after compiling the same application for months , yesterday presented the error

Re: Unable to compile icon

PostPosted: Wed Oct 21, 2015 4:44 pm
by David de Argentina
Same problem with 5.8.6.
UPX packet does not compile fine.
I had to reinstall 5.7.1
Problem were registered yesterday.

Re: Unable to compile icon

PostPosted: Wed Oct 21, 2015 6:55 pm
by Neosoft Support
I can't reproduce this problem here. Both with and without UPX, icons are compiled correctly in 5.8.6. For my test I used a large multi-resolution icon.

Occasionally when you change an app's icon and recompile, Windows will continue to display the old icon because it's stored in Windows' icon cache. To fix this you can manually rebuild the icon cache:

https://social.technet.microsoft.com/forums/windows/en-us/bea47202-d869-4155-8c8f-2a5b8bd7be1d/forum-faqhow-to-rebuild-icon-cache

Also, try right clicking on the exe and choosing properties and see if the correct icon is displayed in the dialog box. If it is then the problem is definitely the cache.

Re: Unable to compile icon

PostPosted: Thu Oct 22, 2015 7:02 am
by Rasl
Solved for me the Panda antivirus was the cause
salu2

Re: Unable to compile icon

PostPosted: Thu Oct 22, 2015 7:41 am
by stu
I had the same problem with the icon when compiling... but in my case I had the Icon on a folder within the C drive. I place it on D drive (or desktop, or anywhere other than a folder in the C drive root) and it worked fine. So basically on 8.1 its requiring admin rights to pack the icon on the final EXE (?) In any case, apparently there's a few different causes... :wink:

Re: Unable to compile icon

PostPosted: Fri Oct 23, 2015 7:10 pm
by Neosoft Support
The default Windows configuration does not work well for programmers. Many things that programmers do routinely, like creating exe files, is viewed with suspicion by newer versions of Windows and many anti-virus utilities.

Windows includes a feature called User Access Control (UAC) described here: https://en.wikipedia.org/wiki/User_Account_Control

Most anti-virus utilities include an option to exclude certain folders from their real-time scan feature. Each anti-virus app handles this differently, so you will need to consult with your anti-virus app's help file to determine how to exclude the folder where you compile your pubs from scanning. An extra benefit is that once you do this, test running and compiling your pubs will be many times faster.

Re: Unable to compile icon

PostPosted: Mon Dec 05, 2016 9:29 am
by jappell
Problem: "Unable to compile icon" error is displayed.
Background: I recently started to have an issue that I never experienced before. The version I have now is 5.8.7 with Windows 10. I removed new antivirus, no change. That left Windows Defender. I turned it off and voila problem fixed! Moments later it automatically turned on, thank you Microsoft. Here is how to make it stop from automatically running. Do not make changes to your registry unless you know what you are doing.

Open regedit and go to

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WinDefend

Open the subkey corresponding to the service you wish to change (WinDefend), and modify the value of 'Start' to equal either "2" (for automatic), "3" (for manual) or "4" (for disabled)

End Result: The "Unable to compile icon" error is now fixed.

Re: Unable to compile icon

PostPosted: Sat Dec 10, 2016 5:41 pm
by Neosoft Support
Windows Defender has an option in settings to set exclusions for specific files and folders. This will turn off the real time scanning for specific files and folders only rather than the entire PC. Programmers often exclude the folders they use to compile their apps. This speeds up compiling exponentially and eliminates strange errors like the one discussed here.